Starting Problems
Close
Login to Your Account
Hello Guest, if you're reading this it means you have not yet registered. Please take a second, Click here to register and in a few simple steps, you will be able to enjoy all the many features of our fine community. It's quick and free. You can dismiss this message by clicking the X in the top right corner.
Polaris ACE Forum - Powered by vBulletin

Starting Problems

This is a discussion on Starting Problems within the ACE Engine and Drivetrain forums, part of the Polaris ACE Garage category; Last night we tried starting my Ace since it hadn't been for about a month. No go. Did a search earlier for possible ideas and ...

Results 1 to 5 of 5

Thread: Starting Problems

  1. #1
    Member
    This user has no status.
     
    fjen's Avatar
    Member #
    941
    Join Date
    May 2014
    Location
    Indiana
    Posts
    62

    Starting Problems

    Last night we tried starting my Ace since it hadn't been for about a month. No go. Did a search earlier for possible ideas and found a thread that mentioned a switch for the brake pedal. Can't find it now, so starting this new one. The post mentioned a switch described as being in the wheel well on the front right side. Not sure if that meant right side standing in front of it or sitting in it? It also mentioned that someone had to really mash the brake pedal to get it to start. Tried that on mine and it works, not right away, but after really stepping on it a few times it will start. Battery voltage is fine, you hear the fuel pump prime when you turn the key, but after that nothing happens unless you really abuse the brake pedal! Any ideas on this and how to fix?

  2. #2
    Senior Member
    This user has no status.
     
    extremegsxr's Avatar
    Member #
    717
    Join Date
    Feb 2014
    Location
    Ohio
    Posts
    191
    Here is the thread on that brake switch problem
    https://www.aceforums.net/forum/9-ace...3-service.html

  3. #3
    Member
    This user has no status.
     
    usstickers's Avatar
    Member #
    1037
    Join Date
    Jul 2014
    Location
    usa massachusetts
    Posts
    80
    Quote Originally Posted by fjen View Post
    Last night we tried starting my Ace since it hadn't been for about a month. No go. Did a search earlier for possible ideas and found a thread that mentioned a switch for the brake pedal. Can't find it now, so starting this new one. The post mentioned a switch described as being in the wheel well on the front right side. Not sure if that meant right side standing in front of it or sitting in it? It also mentioned that someone had to really mash the brake pedal to get it to start. Tried that on mine and it works, not right away, but after really stepping on it a few times it will start. Battery voltage is fine, you hear the fuel pump prime when you turn the key, but after that nothing happens unless you really abuse the brake pedal! Any ideas on this and how to fix?
    You should call your local dealer on that. It's a huge safety factor when you have electrical problems like this. It will probably be warranty issue. (hopefully).

  4. Remove Advertisements
    AceForums.net
    Advertisements
     

  5. #4
    Member
    This user has no status.
     
    fjen's Avatar
    Member #
    941
    Join Date
    May 2014
    Location
    Indiana
    Posts
    62
    Quote Originally Posted by extremegsxr View Post
    Here is the thread on that brake switch problem
    https://www.aceforums.net/forum/9-ace...3-service.html
    Yes! Thank you!

  6. #5
    Member
    This user has no status.
     
    fjen's Avatar
    Member #
    941
    Join Date
    May 2014
    Location
    Indiana
    Posts
    62
    Quote Originally Posted by usstickers View Post
    You should call your local dealer on that. It's a huge safety factor when you have electrical problems like this. It will probably be warranty issue. (hopefully).
    I have just a few days left before my 6 month warranty is up, so no time to waste. Local dealer no good, young kid = shop. Already been there. Going to travel a little farther this time.

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Anyone else starting to wear out suspension components?
    By Scoundrel in forum ACE Suspension
    Replies: 26
    Last Post: 09-22-2014, 11:17 AM
  2. Starting funny
    By rolltidehack in forum ACE Talk
    Replies: 15
    Last Post: 07-21-2014, 09:33 PM

Search tags for this page

polaris ace starting troubles

Click on a term to search our site for related topics.