Head light trouble.
Close
Login to Your Account
Hello Guest, if you're reading this it means you have not yet registered. Please take a second, Click here to register and in a few simple steps, you will be able to enjoy all the many features of our fine community. It's quick and free. You can dismiss this message by clicking the X in the top right corner.
Polaris ACE Forum - Powered by vBulletin

Head light trouble.

This is a discussion on Head light trouble. within the ACE Lighting, Stereo, and Electrical forums, part of the Polaris ACE Garage category; Today was the first time I took my 570 Ace out and it was nothing but ruts, mud holes and lots of water in the ...

Results 1 to 4 of 4

Thread: Head light trouble.

  1. #1
    Member
    This user has no status.
     
    Tinnerdude's Avatar
    Member #
    8761
    Join Date
    May 2017
    Location
    Southwest Washington
    Posts
    50

    Head light trouble.

    Today was the first time I took my 570 Ace out and it was nothing but ruts, mud holes and lots of water in the low spots. What a blast. My problem is that the first mud hole I came to had about 12" of water in it and of course you had to go fast to get thru it. When I got out the other side as I was waiting for the other guy to come thru I noticed dirty water inside my headlight. Does anybody else have this problem with their Ace's? Can you take the headlight lense off the housing and then seal it good so no more water can get in?

  2. #2
    Senior Member
    This user has no status.
     
    MaxximusDesimus's Avatar
    Member #
    1543
    Join Date
    Apr 2015
    Location
    Alberta, Canada
    Posts
    299
    I opened mine up to install halo's & LED lighting. The clips do nothing, the silicone is what holds the lens on. Made post on how to open them, follow exactly & they open fairly easy.

    https://www.aceforums.net/forum/13-ac...-led-mods.html

  3. #3
    Senior Member
    is Planning a Hatfield and Mccoy
    trip
     
    Sporty061200r's Avatar
    Member #
    3865
    Join Date
    Apr 2016
    Location
    Indiana
    Posts
    395
    seems like its just a poor design.. the bulbs do not seal tightly and mine also get water in i take them out and rinse the lenses out when i deep clean the ace.. was thinking about drilling a small 1/16 hole in the housing for a drain.. but havent got around to it
    "you cant fix stupid.. but you can fix ugly"
    "when in doubt pull out"

    2017 Polaris Ace 900 XC, lock and ride roof
    2017 Can-AM DS 90X
    2011 Honda TRX 250x

  4. Remove Advertisements
    AceForums.net
    Advertisements
     

  5. #4
    Junior Member
    This user has no status.
     
    steve72george's Avatar
    Member #
    8938
    Join Date
    May 2017
    Location
    collingwood Ontario
    Posts
    29
    double up on the socket seals

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. need head & cam torque specs for 325 ace.
    By whithardude in forum ACE Talk
    Replies: 3
    Last Post: 05-11-2017, 09:25 AM
  2. Newbie with a question before my head explodes!
    By obieyousonofabeach in forum ACE 570
    Replies: 4
    Last Post: 03-28-2017, 08:30 PM
  3. Replies: 2
    Last Post: 08-01-2016, 09:42 PM
  4. Replies: 6
    Last Post: 03-03-2016, 02:38 PM
  5. Head bolt torque specs
    By Jay430 in forum ACE Engine and Drivetrain
    Replies: 2
    Last Post: 10-13-2015, 07:41 PM