2019 Ace 570 need help with winch mount upper bolts
Close
Login to Your Account
Hello Guest, if you're reading this it means you have not yet registered. Please take a second, Click here to register and in a few simple steps, you will be able to enjoy all the many features of our fine community. It's quick and free. You can dismiss this message by clicking the X in the top right corner.
Polaris ACE Forum - Powered by vBulletin

2019 Ace 570 need help with winch mount upper bolts

This is a discussion on 2019 Ace 570 need help with winch mount upper bolts within the ACE 570 forums, part of the Polaris ACE Forums category; I purchased a KFI winch mount which says it is compatible with a 2019 570. However the space to install the upper mount bolts through ...

Results 1 to 3 of 3

Thread: 2019 Ace 570 need help with winch mount upper bolts

  1. #1
    Junior Member
    This user has no status.
     
    MarkF's Avatar
    Member #
    12322
    Join Date
    Aug 2019
    Posts
    14

    2019 Ace 570 need help with winch mount upper bolts

    I purchased a KFI winch mount which says it is compatible with a 2019 570. However the space to install the upper mount bolts through the frame is blocked by A Arms. Anyone have any advice or tricks to get those bots in?

  2. #2
    Junior Member
    This user has no status.
     
    Johann's Avatar
    Member #
    11874
    Join Date
    Jun 2018
    Posts
    29
    Quote Originally Posted by MarkF View Post
    I purchased a KFI winch mount which says it is compatible with a 2019 570. However the space to install the upper mount bolts through the frame is blocked by A Arms. Anyone have any advice or tricks to get those bots in?
    indont quite remember the trick but it was a pita. Gotta use long pliers and swivels n such. Gl mate

  3. #3
    Junior Member
    This user has no status.
     
    MarkF's Avatar
    Member #
    12322
    Join Date
    Aug 2019
    Posts
    14
    On the left side I was able to pull the upper A Arm bolt because it cleared the winch and install the mounting bolt. On the other side it was near impossible. I was able to get it started using my finger tips and then I used a stubby open wrench a bit and then a stubby ratcheting wrench. No way to torque it to spec though. I was in contact with KFI and they were not aware that 18 & 19 570s had upper A arms.

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •