UPfreebird - Ace 900 SP - Page 3
Close
Login to Your Account
Hello Guest, if you're reading this it means you have not yet registered. Please take a second, Click here to register and in a few simple steps, you will be able to enjoy all the many features of our fine community. It's quick and free. You can dismiss this message by clicking the X in the top right corner.
Polaris ACE Forum - Powered by vBulletin

UPfreebird - Ace 900 SP

This is a discussion on UPfreebird - Ace 900 SP within the ACE 900 SP forums, part of the Polaris ACE Forums category; In the process of installing an older plow to the Ace now. And of course the original mounting bracket does not mount to the Ace,... ...

Page 3 of 5 FirstFirst 1 2 3 4 5 LastLast
Results 21 to 30 of 48
Like Tree9Likes

Thread: UPfreebird - Ace 900 SP

  1. #21
    Senior Member
    is looking for mud!
     
    UPfreebird's Avatar
    Member #
    12000
    Join Date
    Aug 2018
    Posts
    151
    In the process of installing an older plow to the Ace now.
    And of course the original mounting bracket does not mount to the Ace,... so I had to make one.
    Name:  ACE004.JPG
Views: 224
Size:  60.1 KB

    That 3/8" plate will be mounted to the bottom of the Ace.
    Then I'll have to tap and drill the plate to accept the original plow mount.
    It'll come on/off easy enough and I should be able to leave the 3/8" Thick mounting plate on at all times.
    Last edited by UPfreebird; 02-07-2019 at 06:27 AM.
    16' ACE 900 SP

  2. #22
    Senior Member
    is looking for mud!
     
    UPfreebird's Avatar
    Member #
    12000
    Join Date
    Aug 2018
    Posts
    151
    Snowplow has been added!
    Had to include a pulley so I was able to pull the plow upwards instead of in and towards the Ace.
    Name:  Ace Snowplow.jpg
Views: 196
Size:  245.7 KB
    rockman and pgiannetto like this.
    16' ACE 900 SP

  3. #23
    Senior Member
    is looking for mud!
     
    UPfreebird's Avatar
    Member #
    12000
    Join Date
    Aug 2018
    Posts
    151
    So I had my winch wired incorrectly.
    Found that out when I was stuck and needed it the most.
    Apparently the winch connections that are in the front of the Ace are only if your winch has a solenoid.
    Mine does not.

    So I go for a rip and get stuck. Not a big shocker cuz I always tend to test the limits.
    Went to use my winch to pull me out and as soon as there was a load on it,.. I blew the 20A winch fuse.
    No biggie I have more with me. So I tossed in a 25A,.. which instantly blew. Then a 30A ,.. which instantly blew.
    So I shoveled myself out and then wrote the winch company asking how many amps it draws.

    15A with no load.
    60A with 1,000 lb load.
    120A with 2,000 lb load.
    170A with 3,000 lb load.

    My biggest fuse is a 30A.
    So apparently this style of winch needs to be hooked directly up to the motor.
    Which I finally rewired it late last night.
    I haven't tested the winch under load yet,.. but maybe today.
    I'll just put it in neutral, hook the winch up to something,.. and see if it can pull me forward.

    IT BETTER! lol
    16' ACE 900 SP

  4. Remove Advertisements
    AceForums.net
    Advertisements
     

  5. #24
    Member
    This user has no status.
     
    Mudder2's Avatar
    Member #
    12086
    Join Date
    Dec 2018
    Posts
    30
    Name:  5BD3B82D-1C48-43BF-BD20-FB0E9C9D1FD4.jpeg
Views: 165
Size:  476.0 KB
    Check out a Bussman resettable waterproof switched breakers at auto stores, about $30. Have 150 amp, not blown yet, and like the switch to kill power when working on wiring. Hope you have around 6 gauge wire.

  6. #25
    Senior Member
    is looking for mud!
     
    UPfreebird's Avatar
    Member #
    12000
    Join Date
    Aug 2018
    Posts
    151
    Thanks Mudder2. I'll look into that.
    It's all hooked up and ready to go,... but I'll still look into that Bussman.
    I do not have 6 GA wire.
    I went to the store to buy it and didn't want to spend $60 on it.
    So I just went back home and re-routed the wires until it reached the battery, winch, and where I wanted the control buttons to be at.
    16' ACE 900 SP

  7. #26
    Senior Member
    is looking for mud!
     
    UPfreebird's Avatar
    Member #
    12000
    Join Date
    Aug 2018
    Posts
    151
    I've used my winch 3 times since rewiring it.
    Works awesome!

    Got framed up last night going down a snow covered trail.

    I made a few snatch blocks too,... for future pulls.
    Can't wait to try em out. Hopefully it will be when pulling a can am out of the mud.
    16' ACE 900 SP

  8. #27
    Senior Member
    is looking for mud!
     
    UPfreebird's Avatar
    Member #
    12000
    Join Date
    Aug 2018
    Posts
    151
    2" Lift Kit is designed for my Ace 900 SP.
    I am hoping to get the parts spun up this week so I can install it before riding season begins.

    Tired of getting stuck from simply being 'framed up'.
    I'll take and upload some pics after the Lift Kit is installed,... and,... if it works on the first try without having to make a revision. lol

    If it does work out,.. next up will be upgrading my tire size.
    I won't be able to design one of those tho,...
    Last edited by UPfreebird; 04-23-2019 at 01:16 PM.
    16' ACE 900 SP

  9. #28
    Senior Member
    is looking for mud!
     
    UPfreebird's Avatar
    Member #
    12000
    Join Date
    Aug 2018
    Posts
    151
    Belt Recommendations anyone??

    Drove thru some seat deep water yesterday and barely made it out due to a wet and slipping belt.
    Then I had to baby it for the next 2-3 miles by going less than 10 mph so I wouldn't break the belt.
    After 2-3 miles the belt was grabbing again.
    I went straight home tho and didn't try any other dumb stuff for the night.
    I'm gonna need to get a new belt tho asap.
    So,... any recommendations??

    Is the Gates 26C4140 a quality belt?
    16' ACE 900 SP

  10. #29
    Junior Member
    This user has no status.
     
    AUGDOG's Avatar
    Member #
    11722
    Join Date
    Jun 2018
    Location
    S. WI
    Posts
    19
    Don't have a belt recommendation for you but if that happens again with the water there is a drain plug On the bottom of the drive belt housing, Happened to me once And I backed the plug out and drained it and drove off with no problems
    UPfreebird likes this.

  11. #30
    Senior Member
    is looking for mud!
     
    UPfreebird's Avatar
    Member #
    12000
    Join Date
    Aug 2018
    Posts
    151
    Thanks AugDog.
    It must be that Red screw that is the drain plug for it.
    That'll be the first thing I do,... next time.

    Cheers
    16' ACE 900 SP

Page 3 of 5 FirstFirst 1 2 3 4 5 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. UPfreebird - Ace 900 SP
    By UPfreebird in forum Introductions
    Replies: 4
    Last Post: 08-29-2018, 05:11 AM
  2. New Forum - ACE 900 SP
    By 4Nines in forum ACE 900 SP
    Replies: 234
    Last Post: 04-15-2016, 05:41 PM
  3. 2016 Polaris ACE 900 SP First Ride & Review
    By NickJ in forum Polaris ACE News
    Replies: 8
    Last Post: 10-03-2015, 02:51 PM
  4. ACE 900 SP riding the Ridge in Eastern, Ky.
    By ky kodiak in forum ACE Pictures/Videos
    Replies: 0
    Last Post: 10-02-2015, 07:20 PM
  5. Replies: 0
    Last Post: 09-30-2015, 09:44 AM

Search tags for this page

upfreebird

Click on a term to search our site for related topics.