ace 330 no power or lights and broke motor mount bolt
Close
Login to Your Account
Hello Guest, if you're reading this it means you have not yet registered. Please take a second, Click here to register and in a few simple steps, you will be able to enjoy all the many features of our fine community. It's quick and free. You can dismiss this message by clicking the X in the top right corner.
Polaris ACE Forum - Powered by vBulletin

ace 330 no power or lights and broke motor mount bolt

This is a discussion on ace 330 no power or lights and broke motor mount bolt within the ACE Talk forums, part of the Polaris ACE Forums category; so after a top end rebuild and several successful trips in the ace we rode all day and came back to camp. The next morn ...

Results 1 to 6 of 6
Like Tree2Likes
  • 1 Post By mustang
  • 1 Post By mustang

Thread: ace 330 no power or lights and broke motor mount bolt

  1. #1
    Member
    This user has no status.
     
    xp413's Avatar
    Member #
    824
    Join Date
    Mar 2014
    Posts
    60

    ace 330 no power or lights and broke motor mount bolt

    so after a top end rebuild and several successful trips in the ace we rode all day and came back to camp. The next morn the battery was low turned over but slow, jumped it off ran fine. started up a big muddy hill my boy punched it, lost all power. No click, no dash lights, nothing. towed it back battery 12.5 volts. when we got home washed it and found a bolt about 6" long. one of the bolts that connects the engine to trans. any ideas? there are 3 fusible links. im sure one is blown but cant find one polaris diagram where they go.
    2015 Highlifter 1000
    2014 xp1000
    2014 ace

  2. #2
    Member
    This user has no status.
     
    xp413's Avatar
    Member #
    824
    Join Date
    Mar 2014
    Posts
    60
    surely someone has a manual to fix these.
    2015 Highlifter 1000
    2014 xp1000
    2014 ace

  3. #3
    Senior Member
    Supporting Member
    is looking forward to the next
    ride.
     
    Scoundrel's Avatar
    Member #
    746
    Join Date
    Feb 2014
    Location
    Western Washington State
    Posts
    3,051
    I feel your pain. There are a few members with service manuals, maybe one of them will jump in.
    But considering how much you've got into this, I'm surprised you haven't bought one yet.
    ------------------
    I sold my ACE and am no longer a moderator on this forum. In fact I'm not participating on this forum at all. Sending me questions about my previous signatures is not likely to generate a response. But if you ask your question to the forum publicly, I'm sure you'll get what you need.
    Keep the rubber side down!
    -=-=-=-
    Check out my UTV Guide to Washington State at http://www.utvadventuresllc.com!
    -=-=-=-

  4. Remove Advertisements
    AceForums.net
    Advertisements
     

  5. #4
    Senior Member
    is WTF
     
    mustang's Avatar
    Member #
    1104
    Join Date
    Aug 2014
    Location
    NH USA
    Posts
    218
    there are 3 fuseable links on the ace and all three are in the wiring to the starter solenoid ..................

    the relays in the fuse box behind the seat control things like efi relay, chassis relay , each one of these relays control other functions too
    like the chassis relay controls power feeds to lights ,awd ,12 volt receptacles and options
    the efi relay controls turning on the fuel injectors and ignition coil as well as turning on the fan relay and fuel pump relay
    all other fuses are in the box behind the seat

    I would be looking for an unseated relay or a failed relay given all the fuses are good (check the fuses with a ohm meter , visual is not always right)

    and yeah a manual is highly recommended , the electrical system is kinda complex .
    also if your battery or charging circuit voltage goes below 11 volts the ECU is all done , it needs 11 volts minimum to function correctly and it is the master control for everything on an ace electrical circuit .
    Last edited by mustang; 03-28-2015 at 08:45 AM.
    Scoundrel likes this.

  6. #5
    Senior Member
    is WTF
     
    mustang's Avatar
    Member #
    1104
    Join Date
    Aug 2014
    Location
    NH USA
    Posts
    218
    If you have totally no power from battery there is a fusable link in the red battery lead that goes to the regulator..................start there
    Scoundrel likes this.

  7. #6
    Member
    This user has no status.
     
    xp413's Avatar
    Member #
    824
    Join Date
    Mar 2014
    Posts
    60
    Sweet thanks for somewhere to start
    2015 Highlifter 1000
    2014 xp1000
    2014 ace

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. lights
    By billbo in forum ACE Talk
    Replies: 5
    Last Post: 06-10-2016, 02:06 PM
  2. EMP Winch Mount - Slightly used, includes new bolt kit
    By Scoundrel in forum ACE Parts for Sale / Wanted
    Replies: 8
    Last Post: 12-02-2014, 10:41 PM
  3. Trade new kfi winch mount for polaris winch mount
    By Slydogge in forum ACE Accessories
    Replies: 0
    Last Post: 09-25-2014, 07:04 AM
  4. Tail lights always on?
    By Copperhead in forum ACE Lighting, Stereo, and Electrical
    Replies: 3
    Last Post: 05-30-2014, 06:59 AM
  5. LED driving lights/Wiring harness?
    By Luge in forum ACE Talk
    Replies: 14
    Last Post: 04-02-2014, 06:54 PM

Search tags for this page

ignition coil

,

wiring

Click on a term to search our site for related topics.