Polaris ACE Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
I purchased a KFI winch mount which says it is compatible with a 2019 570. However the space to install the upper mount bolts through the frame is blocked by A Arms. Anyone have any advice or tricks to get those bots in?
 

·
Registered
Joined
·
29 Posts
I purchased a KFI winch mount which says it is compatible with a 2019 570. However the space to install the upper mount bolts through the frame is blocked by A Arms. Anyone have any advice or tricks to get those bots in?
indont quite remember the trick but it was a pita. Gotta use long pliers and swivels n such. Gl mate
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
On the left side I was able to pull the upper A Arm bolt because it cleared the winch and install the mounting bolt. On the other side it was near impossible. I was able to get it started using my finger tips and then I used a stubby open wrench a bit and then a stubby ratcheting wrench. No way to torque it to spec though. I was in contact with KFI and they were not aware that 18 & 19 570s had upper A arms.
 

·
Registered
Joined
·
1 Posts
Block the front wheel up as high as it will go. This will allow you to reach under the “A” arm bolt with one hand and reach above the bolt with the other hand. You will only be able to reach where the mounting bolt is to go with two fingers on each hand, but that should allow you to maneuver the mounting bolt in and get it started. The space is too tight for a standard wrench to be used to tighten the bolt so you need a short wrench. In my case, I cut off a cheap (Harbor Freight) wrench to tighten the mounting bolt. I mounted a KFI winch mount a few weeks ago, and this method worked for me. Good luck!
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5
As I mentioned above I used a ratcheting stubby wrench.

Not an ideal setup but should be strong enough
 
1 - 5 of 5 Posts
Top