Polaris ACE Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
After having my ace for two weeks I have a rod knock. So I went out to my land for the day to ride. After warming it up went for a ride with my brother and then.... I notice lack of power then a heard knocking from the motor. I knew what happen but did not know why. The ace had 32 miles on it and it threw the main bearing. Now I did not beat the **** out of it, I did go in the mud a lot of mud but did not get stuck or pin it wide open. I never had water in the oil. To add to it my brother tows me back to the truck with his new 2015 Honda pioneer 500. In which he let me know how he feels about polaris. This dose not change my opinion. Yes I was upset when this happen, but I called my dealer they had me bring it in the next day they looked all over and said yea you have a bad motor. They put a brand new motor in under warranty, gave me an extended warranty for piece of mind. It took 2weeks to get it back. But all said in done I now have 300 miles on it and not any problems. Fyi my 330 ace is way faster the the Honda p5 and just over all just better. Has anyone else blow a motor because of a defect(not because you sucked up water no motor can take that)?
 

·
Registered
Joined
·
80 Posts
friend of mine lunched the motor at 29 hours took it back and they replaced it no questions asked. he bought it back in sept 2014. I like the setup of the ace and I just bought one in January, but got the 4.5 extra warranty for 500.00 more just for that reason. sounds like the new motor is doing good for you.
 

·
Registered
Joined
·
1,747 Posts
After having my ace for two weeks I have a rod knock. So I went out to my land for the day to ride. After warming it up went for a ride with my brother and then.... I notice lack of power then a heard knocking from the motor. I knew what happen but did not know why. The ace had 32 miles on it and it threw the main bearing. Now I did not beat the **** out of it, I did go in the mud a lot of mud but did not get stuck or pin it wide open. I never had water in the oil. To add to it my brother tows me back to the truck with his new 2015 Honda pioneer 500. In which he let me know how he feels about polaris. This dose not change my opinion. Yes I was upset when this happen, but I called my dealer they had me bring it in the next day they looked all over and said yea you have a bad motor. They put a brand new motor in under warranty, gave me an extended warranty for piece of mind. It took 2weeks to get it back. But all said in done I now have 300 miles on it and not any problems. Fyi my 330 ace is way faster the the Honda p5 and just over all just better. Has anyone else blow a motor because of a defect(not because you sucked up water no motor can take that)?

Glad they took care of you on the motor, and give my condolences to your brother for buying that butt-ugly pioneer 500....lol
 

·
Registered
Joined
·
1 Posts
After having my ace for two weeks I have a rod knock. So I went out to my land for the day to ride. After warming it up went for a ride with my brother and then.... I notice lack of power then a heard knocking from the motor. I knew what happen but did not know why. The ace had 32 miles on it and it threw the main bearing. Now I did not beat the **** out of it, I did go in the mud a lot of mud but did not get stuck or pin it wide open. I never had water in the oil. To add to it my brother tows me back to the truck with his new 2015 Honda pioneer 500. In which he let me know how he feels about polaris. This dose not change my opinion. Yes I was upset when this happen, but I called my dealer they had me bring it in the next day they looked all over and said yea you have a bad motor. They put a brand new motor in under warranty, gave me an extended warranty for piece of mind. It took 2weeks to get it back. But all said in done I now have 300 miles on it and not any problems. Fyi my 330 ace is way faster the the Honda p5 and just over all just better. Has anyone else blow a motor because of a defect(not because you sucked up water no motor can take that)?

I just had the same issue with mine except mine is at 400 miles. Ever since it had about 10 miles it had a slight knock that you could barely tell was there. Ran perfect always but now motor is done. If anyone knows any places where I could get a motor please let me know.
 

·
Registered
Joined
·
3,051 Posts
I just had the same issue with mine except mine is at 400 miles. Ever since it had about 10 miles it had a slight knock that you could barely tell was there. Ran perfect always but now motor is done. If anyone knows any places where I could get a motor please let me know.
That sucks. Welcome to the forum, and I hope you find a good one at a decent price.
 
1 - 7 of 7 Posts
Top