Polaris ACE Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Well while out on a ride over the weekend clipped a stup when I was going 5mph and bent the left front WAY out! I'm going to tear apart and see what's up today. Is the a know thing that breaks on these struts?
 

·
Registered
Joined
·
420 Posts
Hopefully it just bent the a-arm and didn't damage the strut or hub. The ball joint is mounted in the strut not the a-arm on these. Could be tierod issues as well.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #4 ·
I have not had time to tear it down. I just adjusted the tie rod as far as I could and its almost strait now. The wheel has a tiny bit of a tick toc when you pull it in and out so im afraid its that aluminum strut knuckle has cracked and the click clack I hear is the bearing not tight in the strut hub anymore :/ My rhinos I would bend the knuckle where the tie rod end connects sometimes from huge hits off jumps but this one is not bent there for sure. I am 90% sure the a arm is fine. Its crazy I visually looked at it for an hr and so did many others measuring everything from tire to fender distance/ tie rod end to tire distance/ etc and everything measures up but it bent that left front toe WAY out. If its not a cracked hub all else I can see is maybe the steering rack stretched but no way thats possible. Plus the right side is perfect when you hold the wheel strait the right wheel is strait so its pretty much has to be that strut mount hub.
 
1 - 4 of 4 Posts
Top