Polaris ACE Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
173 Posts
Discussion Starter · #1 ·
Hey everybody! Just curious if anyone else is having issues with the OEM decals on the Ace bubbling, tearing, and loosing adhesion? I am having to replace some of my decals due to all of these issues. When my dealer went to order me some new decals one was on back order so it made me wonder if their are other people with this issue. I take great care of my Ace inside and out haven't trashed any of it and these decals are in my opinion are made very cheap. My hubby has a 2013 Ranger and before I bought the Ace I had a 2013 Sportsman 400 and never had an issue with the decals. My washing materials are all the same as I have been using in the past and everything! I am curious please chime in and let me know. Even the other Ace my dealer has bubbles in the decals!
 

·
Registered
Joined
·
3,051 Posts
No bubbles in mine, no damage at all to them.
But then my ACE did not have weather-checked tires either, and there were many reports of those.
I suspect it has to do with bad production runs, or local environmental effects when they were being stored/shipped.
Sorry to hear you're having decal issues.
 

·
Registered
Joined
·
79 Posts
Some of my decals came up a bit, but that may be from getting a bit too close with the pressure washer....
 

·
Registered
Joined
·
46 Posts
had trouble with mine. They came off on both sides and my dealer ordered me all new ones and put them on.
 

·
Registered
Joined
·
49 Posts
Mine bubbled and pealed off. I also had the tires that had the issue. That was taken care of, I will call the dealer tomorrow and see what they say.
 
1 - 6 of 6 Posts
Top