Polaris ACE Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
I bought a 2018 ACE 570 EPS a couple weeks ago. 370 miles, excellent condition all over. The dealer told me it was previously owned by an older gentleman who enjoyed leisurely trail rides.

Sometimes it idles steady at 1250, other times it stutters with the RPMs between 1150 and 1350. I can hear and feel the misses. Acceleration is strong, and runs solid at speed. Let of the gas and it will pop or backfire once or twice. In low range it misses and pops. I intend to plow and pull a trailer, so the low range problem is important.

Figuring that it sat for a long time, I pumped out the gas, replaced it with new BP 87 with ethanol treatment and Gumout Regane fuel system cleaner. Changed the plug with a NGK MR7F gapped to 0.75mm. Still missing and popping.

The dealer transferred the extended warranty to me, which expires 5/31/2021, so I'm in need for ideas.

I read everything I could find on the forum here and Google. Seems like
  • Intake or exhaust leak. Checked, haven't found anything loose or broken.
  • ECM needs re-flashed - why?
  • Bad Fuel pump, causing a lean condition at idle
  • Bad Voltage regulator, which might cause low fuel pressure at idle
  • Bad idle air control valve, causing the wrong air mix at idle
I would very much appreciate anyone offering some advice for my situation. Thanks
 

·
Registered
Joined
·
47 Posts
I would take it to the shop immediately. Shop time is expensive here. It is likely a sensor or computer malfunction.
 

·
Registered
Joined
·
15 Posts
“The dealer told me it was previously owned by an older gentleman who enjoyed leisurely trail rides.”

The dealer told you that, hmmmm. I’ve heard that many times. Apparently only old people own ORV’s.

I agree with billmay if you have it under warranty take it in immediately as you only have a few days left. Problem being they might be booked and not able to get you in for three weeks therefore missing the warranty.

I personally don’t think it’s the voltage regulator
When idled mine would die and it would give you check engine light, and you could tell it was electrical. The other time it read over voltage 18.4 and would cut it off mid riding or when you stopped and then a slew of indicators.
 
1 - 4 of 4 Posts
Top