Polaris ACE Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
We have a 2014 Ace 570 and it will not start with the key. Not sure what is going on.



Also, the lights nor the AWD would work Initially there was a code of 520207 4. I checked wires and connections under the dash. I also checked the fuse box behind the seat and nothing was blown. I am not sure how to check the relays so I tried swapping some around. I learned the ones with yellow writing on top will not interchange with the ones with white writing on top (I am not an electrical guy by any means) So no luck there.



I unplugged/plugged everything I could find and then started tearing the floorboard out and front end off hoping to find something obvious.



This is also a strange part. I now had the same code 520207 but this time there was a 5 as the last number. The owners manual doesn't say much about this.



I read in other forums that you can take out the fuse for lights. When I did this the Ace would not start but the codes went away.



The only way I can get it to start is to jump the solenoid. The starter seems to drag but I attribute this to the connection I am making with a screw driver.



The remote wires too the solinoid are not getting current I believe because I replaced the solinoid and nothing





Thanks!
 

· Registered
Joined
·
14 Posts
When you say it won’t start, does the starter motor turn the engine but it won’t fire? Is there a click from the solenoid? Have you checked the brake pedal interlock?
Do all the dash indicators go on when you turn the key?
When first turning the key on, you should hear the fuel pump pressurizing for about 3-5 seconds.


Sent from my iPhone using Tapatalk
 
1 - 2 of 2 Posts
Top