Polaris ACE Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Im almost 3 months in on mine. Have had a busted headlight housing they fixed when i took it in for the 1st service.

Went out riding after the 1 st service. In Kansas no doubt, 100 or so miles away from me. Huge oil leak. When they did the service they tightened the oil filter cover too tight and cracked it internally. They fixed it but they had it for 2 weeks.

After 4 days I always have to put a charger on it if I don't start it. They checked everything on it and found nothing. I own alot of atvs. 1st time ive had this problem.

My back tire goes flat every other couple days too. since day 1. The rubber looks in and out where the bead is. Like its deformed.

All the metal underneath, frame and what not is beginning to rust in alot of places.

stalls out when u hit a water hole too. I just never seen anything like it before. Its all left me pretty shocked actually. My 1st polaris and this my experience. Its still a good machine.
 

Attachments

·
Registered
Joined
·
3,051 Posts
Im almost 3 months in on mine. Have had a busted headlight housing they fixed when i took it in for the 1st service.

Went out riding after the 1 st service. In Kansas no doubt, 100 or so miles away from me. Huge oil leak. When they did the service they tightened the oil filter cover too tight and cracked it internally. They fixed it but they had it for 2 weeks.

After 4 days I always have to put a charger on it if I don't start it. They checked everything on it and found nothing. I own alot of atvs. 1st time ive had this problem.

My back tire goes flat every other couple days too. since day 1. The rubber looks in and out where the bead is. Like its deformed.

All the metal underneath, frame and what not is beginning to rust in alot of places.

stalls out when u hit a water hole too. I just never seen anything like it before. Its all left me pretty shocked actually. My 1st polaris and this my experience. Its still a good machine.
That is a lot of issues to have with a new machine, and I am sorry you are having that experience.
I assure you it's not the norm, for the ACE or for Polaris.

The bad tire thing is something we've heard here before. We've seen photos of one deformed tire (not bad enough to leak) and many reports of weather-cracked tires.
That sucks but it's easily fixable, and the stock tires are pretty much useless anyway.

The headlight housing, well, that's small potatoes, and I am glad they fixed it.
The oil leak due to over-tightening - mistake/incompetence at the dealer. Sucks, and am glad they fixed it.

The underbody on mine is rusting in many places where I had smacked it with rocks while riding. It has happened to every ORV I've ever owned. But it's just surface rust, and only where the rocks have chipped the paint off. Is yours rusting under the paint, and really thick flaky rust that comes off in scales when you brush it?

Stalling out when you hit a water hole seems odd, like a bad ground or something. Not sure what to make of that, but suggest that you have your dealer check it (or find another dealer).
 

·
Registered
Joined
·
201 Posts
I've got over a 1000 miles on mine and have had no issues as of yet, now I did take it back for the first service but when any one touches my rides it always get the Wrights inspection before it leaves. If it's not right your gonna fix it then and there, after that I do all of my own service ( yes I keep all info detailed in a book). Sorry to hear of your problems and I hope you get everything straighten out.
 

·
Registered
Joined
·
72 Posts
Guys,I think I'm going to take the plastics off and spray mine with Fluid Film ,it creeps into everything and if you get the kit it has a spray gun with adjustable spray tip and flexible extension wands to spray inside frames and things.it sprays like a polyurethane then creeps into all the seams, nooks, Water beads off. you spray everything except the windshields and the brakes.does not harm paint ,plastics or electrical.I did and O2 F250 not a spot of rust after a hard winter in the north I was sold.I also ride a mountain /fat tire bike on the beach,sand and salt wash bead right off. The exhaust and engine will burn if off if you get over spray on it.They sell by the gallon and also have spray cans.
if i remember correctly i think this stuff was developed back in the 50s used to spray steel ballast tanks in ships to prevent rust and is used to spray heavy equipment when shipping overseas (Salt Spray damage) and when used in heavy corrosive conditions.I think its a natural linseed oil based product.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
I didnt check it all out till it broke down in Kansas. I guess I just figured the dealer would what I payed them to do. I too do my own service, but I decided to let them do the first one. As far as the rust Scoudrel asked about Its just chipped everywhere, but also rusting at the connections where bolts are. I havent addressed it yet. I cant work on it all the time, but its exactly what I been doin. I did ask the dealer about the stalling out and they didnt know. Wheels and tires are on my list along with alot of other things. 200 here and there adds up quick. I will say tho is a great machine when running right. I rode 80 something miles a couple days ago with zero issues. I have 2 boys 13/14 and they love it and it seems perfect for them. I have 160 acres south of Stillwater OK and its really just red mud or dust a lil bit of rock climbing and then theres the Cimarron River. Oh reminds me I went thru quick sand 1/4 mile of it i suppose and the machine did great The honda rancher in the pics above didnt make it. The photo of all three atvs with that pelican lying there. All that in the background was quicksand. Thats another thing. Those Pelicans are migrating and they are everywhere dead on the river. Last year it was Flathead.
 

·
Registered
Joined
·
80 Posts
I didnt check it all out till it broke down in Kansas. I guess I just figured the dealer would what I payed them to do. I too do my own service, but I decided to let them do the first one. As far as the rust Scoudrel asked about Its just chipped everywhere, but also rusting at the connections where bolts are. I havent addressed it yet. I cant work on it all the time, but its exactly what I been doin. I did ask the dealer about the stalling out and they didnt know. Wheels and tires are on my list along with alot of other things. 200 here and there adds up quick. I will say tho is a great machine when running right. I rode 80 something miles a couple days ago with zero issues. I have 2 boys 13/14 and they love it and it seems perfect for them. I have 160 acres south of Stillwater OK and its really just red mud or dust a lil bit of rock climbing and then theres the Cimarron River. Oh reminds me I went thru quick sand 1/4 mile of it i suppose and the machine did great The honda rancher in the pics above didnt make it. The photo of all three atvs with that pelican lying there. All that in the background was quicksand. Thats another thing. Those Pelicans are migrating and they are everywhere dead on the river. Last year it was Flathead.
Thanks for letting this info out to us, its nice to get the heads up on things we should keep an eye out for. Sorry you got to be the test pilot for us all.
 

·
Registered
Joined
·
12 Posts
Mine has had a couple issues
Stalled a couple times out of the blue. Restarted fine.
Four or five times when first started, it seems like it's stuck in four wheel drive. Steering wheel shakes, front wheels dig into ground, strong resistance to motor.after a few minutes of running or driving in reverse, the tires free up and acts normal. Can only say its similar to my sportsman 500 occasionally pulling strongly to the right for a distance then again freeing up. Possessed??
Plastic wrap protectant during shipping shredded and blackened 570 blue plastic but not real apparent, almost blends in with decals.
Otherwise, so far, so good.
 

·
Registered
Joined
·
420 Posts
Four or five times when first started, it seems like it's stuck in four wheel drive. Steering wheel shakes, front wheels dig into ground, strong resistance to motor.after a few minutes of running or driving in reverse, the tires free up and acts normal. Can only say its similar to my sportsman 500 occasionally pulling strongly to the right for a distance then again freeing up. Possessed??
check the front end alignment...it seems pretty much every machine out there has the toe set wrong from the factory...either both or just one out of adjustment.
 

·
Registered
Joined
·
72 Posts
Took the ace apart tonight most of the plastics,floor pan top & bottom front & rear plastics. Going to fine spray the entire machine down with fluid film to prevent rust also water and dirt will bead off and wash off easy. I found one of the engine case bolts loose to the top left of the oil filter backed out about 1/4"3/8" in just sitting there .I have 10 miles on it also the front alignment was wacked @ O miles.I guess it was lunch time when they were putting the cases together.
I did notice on my short ride quite a bit of wet mud stays trapped between the floor pan and skid pan leaving the frame exposed to continuous damp mud that will be wet.I also noticed all the electrical connections are eye looped and nutted to a stud are exposed?
 

·
Registered
Joined
·
358 Posts
Guys,I think I'm going to take the plastics off and spray mine with Fluid Film ,it creeps into everything and if you get the kit it has a spray gun with adjustable spray tip and flexible extension wands to spray inside frames and things.it sprays like a polyurethane then creeps into all the seams, nooks, Water beads off. you spray everything except the windshields and the brakes.does not harm paint ,plastics or electrical.I did and O2 F250 not a spot of rust after a hard winter in the north I was sold.I also ride a mountain /fat tire bike on the beach,sand and salt wash bead right off. The exhaust and engine will burn if off if you get over spray on it.They sell by the gallon and also have spray cans.
if i remember correctly i think this stuff was developed back in the 50s used to spray steel ballast tanks in ships to prevent rust and is used to spray heavy equipment when shipping overseas (Salt Spray damage) and when used in heavy corrosive conditions.I think its a natural linseed oil based product.
Love the FluidFilm. Coated my entire truck underneath to prevent rusting. Worked like a charm.
 

·
Registered
Joined
·
72 Posts
Im a believer! took most of the plastics off push bars etc front wheels ,seat and sprayed the entire Ace top to bottom in out over under inside frame tubing with the spray gun like fine polyurethane everywhere I mean everywhere. then let it bake in the sun all day.crept into every nut bolt nook weld It was a lot of work but worth it in the long run No rust and the mud gonna fall off on clean up. and its cheap too the kit is worth every penny with the spray gun with the adj.tip and wands.I buy by the gallon,never goes bad,I also have rags soaked in the stuff I use to wipe things down.have to spray the new truck before winter and the trailer. bet part is minimal to no prep you can spray over light surface rust,soaks right in -done.D
 

·
Registered
Joined
·
358 Posts
You got that right! I had some surface rust starting around edges of body plus under the truck after the snows and salt last winter, so I sprayed it all, rust had stopped, turned black, looks great. Also sprayed the leaf springs. Much quieter when I cross a bridge on the interstate, or drive on washboard roads! Great stuff!
 
1 - 12 of 12 Posts
Top